US Intervention compatibility Update for BF2 1.5

Note: This News Post has been updated. Please read the new instructions on how to install the updated hotfix. Guedoe encountered some hard drive errors during the creation of the first hotfix released yesterday so it basically destroyed the USI.17 installation of those who have installed yesterday’s version. We are very sorry and embarassed for this incident and hereby give you the updated files. All you have to do is reinstall USI 0.17 and then apply the small 0.2 meg hotfix.

After DICE recently released the BF2 1.5 Patch, many mods lost their compatibility to this new version. Other mod teams such as Project Reality, Forgotten Hope 2 and Sandbox already have released a hotfix to make their versions compatible with 1.5, and now it’s our turn to do so. We don’t have included anything new or fancy, we only changed the things that made USI crash when played with BF2 1.5.

So here we are with our updated hotfix. What it does: It patches the objects_server.zip in your mods/usi.17/ folder and updates the mod description so it says 0.17d in the community tab.

Hotfix 0.17d – 0.2 MB
download at FileFront.com
download at RapidShare.com

How to install:
– download the small executable file
– install it following the description
– play the game!

Make sure you have USI 0.17 and BF2 Patch 1.5 installed!

In case you own a server, you will have to install it on your local PC and then just upload the new objects_server.zip and mod.desc to your server’s /mods/usi.17/ folder. Overwrite the existing files and you’re set. If you encounter any problems, feel free to let us know. As always, when you have bugs or feature requests, you can find the proper ways to report them on our homepage. Have fun playing USI 0.17 with BF2 1.5 compatibility, hope to see you soon.

– The USI Dev Team

Add a Comment